MPLS P config Phase 1 – Get the Links up

I have broken down this phase (and all subsequent phases as well) into tasks, as I tend to remember processes better when I have a list. If this doesn’t work for you, try something else.

TASK 1: Check Interfaces, below P1 is just shown, but I checked them on all P routers

P1#sh ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
FastEthernet0/1 unassigned YES unset administratively down down
FastEthernet1/0 unassigned YES unset administratively down down
FastEthernet1/1 unassigned YES unset administratively down down

TASK 2: Bring all interfaces up on all P Devices

P1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
P1(config)#int range fa0/0 – 1 , fa1/0 – 1
P1(config-if-range)#no shut

P2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
P2(config)#int range fa0/0 – 1 , fa1/0 – 1
P2(config-if-range)#no shut

P3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
P3(config)#int range fa0/0 – 1 , fa1/0 – 1
P3(config-if-range)#no shut
TASK 3: Now check if cdp is running: again, I checked all devices.

P3#sh cdp
Global CDP information:
Sending CDP packets every 60 seconds
Sending a holdtime value of 180 seconds
Sending CDPv2 advertisements is enabled

Yip!

TASK 4: So check what is connected to what:

P1#sh
*Sep 18 17:22:11.919: %SYS-5-CONFIG_I: Configured from console by console
P1#sh cdp nei
Capability Codes: R – Router, T – Trans Bridge, B – Source Route Bridge
S – Switch, H – Host, I – IGMP, r – Repeater, P – Phone,
D – Remote, C – CVTA, M – Two-port Mac Relay

Device ID Local Intrfce Holdtme Capability Platform Port ID
P2 Fas 0/0 163 R B 7206VXR Fas 0/0
P3 Fas 0/1 131 R B 7206VXR Fas 0/0

Total cdp entries displayed : 2
P2#sh cdp nei
Capability Codes: R – Router, T – Trans Bridge, B – Source Route Bridge
S – Switch, H – Host, I – IGMP, r – Repeater, P – Phone,
D – Remote, C – CVTA, M – Two-port Mac Relay

Device ID Local Intrfce Holdtme Capability Platform Port ID
P1 Fas 0/0 173 R B 7206VXR Fas 0/0
P3 Fas 0/1 159 R B 7206VXR Fas 0/1

Total cdp entries displayed : 2

P3#sh cdp nei
Capability Codes: R – Router, T – Trans Bridge, B – Source Route Bridge
S – Switch, H – Host, I – IGMP, r – Repeater, P – Phone,
D – Remote, C – CVTA, M – Two-port Mac Relay

Device ID Local Intrfce Holdtme Capability Platform Port ID
P1 Fas 0/0 139 R B 7206VXR Fas 0/1
P2 Fas 0/1 136 R B 7206VXR Fas 0/1

Total cdp entries displayed : 2
In a real world or exam scenario, I would note this lot down on my own diagram.

TASK 5: Assign IP addresses:

So, there is no specific design for the IP ranges here, so we can apply them any way we want to as long as it conforms to the 10.1.x.y/24 range. I have used the following:

P1 FA0/0 – P2 link FA0/0: 10.1.1.0/24 with P1 having .1 and P2 having .2 addresses
P1 FA0/1 – P3 link FA0/0: 10.1.3.0/24 with P1 having .1 and P3 having .3 addresses
P2 FA0/1 – P3 link FA0/1: 10.1.2.0/24 with P2 having .2 and P3 having .3 addresses

Again, I would note this down as well.

P1
interface FastEthernet0/0
description Link to P2
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
description Link to P3
ip address 10.1.3.1 255.255.255.0
duplex auto
speed auto
end

P2
interface FastEthernet0/0
description Link to P1
ip address 10.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
description Link to P3
ip address 10.1.2.2 255.255.255.0
duplex auto
speed auto
end

P3
interface FastEthernet0/0
description Link to P1
ip address 10.1.3.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.2.3 255.255.255.0
duplex auto
speed auto
TASK 6: Now comes the IMPORTANT bit, CHECK your links:

P1#ping 10.1.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 4/19/40 ms
P1#ping 10.1.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/18/20 ms

P2#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/26/60 ms
P2#ping 10.1.2.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/16/20 ms
P3#ping 10.1.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 16/19/20 ms
P3#ping 10.1.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 16/24/36 ms

TASK 7: The Loopbacks.

This is another one of those things where a bit of interpretation is needed.  The task list says:

All ISP 1 P loopbacks will be in the range of  172.22.1.x/32

So presumably we can number these sequentially:

P1

interface Loopback0
ip address 172.22.1.1 255.255.255.255

P2

interface Loopback0
ip address 172.22.1.2 255.255.255.255

P3

interface Loopback0
ip address 172.22.1.3 255.255.255.255

 

We will check this lot in a bit, but you could check it now with the show ip int brief command.

 

 

Leave a comment